Beveiligingsonderzoeker Jason Doyle heeft een drietal lekken ontdekt, die gebruikt kunnen worden om Nest-camera's van Google te laten crashen en opnieuw te laten opstarten. Hij stelde Google in oktober van de lekken op de hoogte, maar er zou tot nu toe geen patch zijn uitgekomen.

Doyle zet zijn bevindingen uiteen in een GitHub-post. Daarin meldt hij dat het lek bestaat in software met versienummer 5.2.1, die aanwezig is in de Dropcam, Dropcam Pro en de Nest-camera's voor binnen en buiten. Via twee van de drie kwetsbaarheden zijn de camera's binnen een korte afstand opnieuw op te starten. Dit is volgens Doyle problematisch, omdat de camera's gedurende die tijd niet kunnen opnemen. Deze kwetsbaarheden zijn te gebruiken via bluetooth low energy, dat na de installatie van de camera's standaard ingeschakeld is. Door verbinding te maken met de camera, kan een kwaadwillende in het eerste geval een bepaalde ssid instellen waardoor het apparaat via een buffer overflow crasht en opnieuw opstart. In het tweede geval is eveneens een buffer overflow teweeg te brengen door een versleuteld wachtwoord in te stellen.

Het derde lek maakt het mogelijk om de camera met een nieuw wifi-netwerk verbinding te laten maken. Dit proces duurt ongeveer 60 tot 90 seconden, waardoor er tijdelijk geen internetverbinding bestaat. Als de camera uiteindelijk geen verbinding kan maken, keert hij terug naar het oorspronkelijke netwerk. Doyle stelt dat hiermee de opname van de camera tijdelijk onderbroken kan worden, doordat er geen lokale opslag aanwezig is.

De onderzoeker laat aan The Register weten dat er geen workarounds zijn, omdat bluetooth niet uit te schakelen is. 

Alles bij de bron; Tweakers


 

Abonneer je nu op onze wekelijkse nieuwsbrief!
captcha